Used Edwards vacuum pump not working for more than 30 sec

Hey folks!

I just bought a used Edwards E2M18 off of eBay.
After a couple of weeks sitting in my shop I finally decided to get it going.

I just filled it with some oil (lightly used oil just to lube it up before I change it to fresh).

I’ll turn it on, it roars, does the sucky sucky, then after about 30 seconds it just shuts off.

I’ve tried browsing some FAQ but there doesn’t seem to be a clear answer.

Before I start screaming at the eBay seller I’m curious if anyone’s encountered this before?

Once I shut it off I’ll press the reset button on the back and it’ll run again for the same amount of time.


Thermal overload is kicking the motor off


It feels like it’s quite warm for running it for 20 seconds at a time?

What are the likely issues?

Its a 120//208-230V model.
It had a 120V plug when initially shipped, but I snipped the end off and put a 220V plug on it.

The wire gauge from the pump is 14, says dry 60C 300V PT2 on the wire.


Thx, took a gander at that before :slight_smile: I’m thinking I might need to change some wiring on the Inside from the 110 to 220v. Will muck around and see what’s up


Do a search in that manual for overload. Couple of different things could be causing it

1 Like

So my pump is an older model. The manuals aren’t exactly accurate unfortunately. :frowning: Might have to just got back to 110V and dump some extra money on a big breaker and another 40ft of cabling.

The newer models have a 120-220v switch on the top inside the motor wiring box. Maybe I’ll call the Edwards guys on Monday. This one just has a starting capacitor on it.

I see it says 115V on there. Guessing that needs to be changed.

1 Like

Not as fancy as the newer ones :stuck_out_tongue:

I know there’s a switch up top on the new guys.

1 Like

Pull the motor apart and check the brushes


Where are you located? There are usually authorized service centers who can refurbish to like new! Worth the investment.

1 Like

Sounds like a problem with your motor, have you tried putting a meter on the leads yet?


It’s likely a motor/electrical issue? I’ve got my electrician who works for herb coming in on Monday.

I’m wondering if the newer models just have both capacitors built into the top and that’s my issue?

The wiring diagrams don’t really help in the manuals since this one’s so old. Hopefully Edwards gets back to me on Monday as well.

You say that it shuts off after about 30 seconds, it could be that the start and run capacitors are not hooked up correctly.

Motor is meant to run on single phase, correct?

1 Like

Yup, single phase. It had a 110V plug on it when I bought it. I swapped it to a 220V because I didn’t want to buy a new 90A breaker :stuck_out_tongue:

I’m thinking there-in lies my problem

Yep, you cant just swap the plug, if you want it you run on 240 you gotta mess with the windings on the motor. That’s only if the motor is capable of making the swap.

Right now you’ve got 120v going to both your positive and negative wires individually.

That fucking pump needs 90a dedicated circuit?


Just on startup it hits 75A or something on 110. The 220V is at 35A. Only 11/5.5A draw on running.

Yeah, so it’ll handle both voltages, it’s designed to. I’m just not sure how to do the swap and I can’t find the manual for older models.

Forgive me I didn’t read your full post. You put a 220 plug on even though the motor states 115 and came with a 115 plug?

Edit the motor states both voltages.

1 Like

Your start capacitor is what allows your amperage to shoot up to allow the motor to run, you only need to size the breaker for the amperage while running.

1 Like

Yeah lol, real dumb I know. The motor says both 110 and 220 as per the picture above. I’m definitely learning lol.

Oh shit… I just looked closer… I think it literally shows me on the plate how to hook it up different

Yes it does did u wire it up per the data plate for 220?